Ninja H2 banner

1 - 20 of 22 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Is anyone having a problem with the h2 after it warms up running ruff down low if you are trying to just cruise at a low speed. And if so is there any way to fix it. I love my h2 the power is awesome but I just wish my low end was a bit more smooth .I would say its between 2 and 4 rpm...thanks:confused:
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Yours sounds nice and smooth mine gets very chuggy and you fined yourself using the clutch a lot to smooth it out...
 

·
Registered
Joined
·
2,027 Posts
Something isn't right.She's got a quick pulsating engine note going on.You can hear it there...mild cruising(and 1st and second lower speed riding)...and also...on my longer vids..it's doing this at various speeds and gears,but consistently.She wasn't doing this when I first started riding her.Anyone elses doing this...or have some insight as to what this could be?The chain is kept well lubed.Slack is correct.Sprocket isn't worn.It seems to be keeping time with the rear wheel revolutions.As the bike speeds up,so does the pulse.


I did the pipe mod,and the flash.IDK IF it was doing this prior to that...it may have been and I didn't notice it?I don't think so...it's kinda noticeable now...to me anyway.
 

·
Registered
Joined
·
2,027 Posts
Again...I can't get the code to embed on this site.My other site...videos go right in just changing the /v/ portion.


It idles fine.I'd say it starts about in the 2K range.Laying on the gas...it's still there....I'll post another vid.Where it's very clear...gotta upload it first.
 

·
Registered
Joined
·
587 Posts
Again...I can't get the code to embed on this site.My other site...videos go right in just changing the /v/ portion.
All I did was drop the s in https. Better watch out silver all the roll racing sickees are noticing your page lol I held them at bay by saying this was just a test video but their thirsty for more lol I think if you gps a top speed run you'd get a couple views... Would be nice to see speedo and gps right next to each other. That's always cool. I like your chin view and am considering it.
 

·
Registered
Joined
·
2,027 Posts
Did a top speed today.She wouldn't rip past 190.Pretty much confirmed(to me)that the gearing is holding her back.She also did 190 when she was totally stock.Has to be the gearing.
 

·
Registered
Joined
·
587 Posts
Did a top speed today.She wouldn't rip past 190.Pretty much confirmed(to me)that the gearing is holding her back.She also did 190 when she was totally stock.Has to be the gearing.
I can say that the bmw is limited by gearing and not by ecu like my 10r. My 10r with stock gearing will do 193 gps once derestricted. Stupid high gearing. Why most go -1 +3 on my bike. Will you change gearing and if so I bet it won't really hurt its get up and go :D
 

·
Registered
Joined
·
2,027 Posts
Still no comments on the sound?C'mon you guys...surely you've heard this before somewhere?If not with your bikes...maybe someone elses?
 

·
Registered
Joined
·
2,027 Posts
Does it sound like mine?There's a definite light pulsing sound happening at cruise.Almost like if you were riding over very mild lateral cracks in the road...but that's not it.It's very quick as it's doing this.I've heard this on other sportbikes...a few...VERY noticeable.I can't tell if it's the drive train or what.Everything's adjusted right.I'll check the chain slack again,maybe take a bit out and see how that does.

Also...I have no exhaust valve(you mean in the cat,right?) anymore.That's gone.
 

·
Registered
Joined
·
2,027 Posts
Okay...I'm relieved to report...it WAS the chain slack.It looked right...but it wasn't.Tightened it up just a bit...perfect!NO NOISE.(WHEW).Also weighed my baby...500 on the nose.(full tank).So if you guys start hearing that noise...you heard it here first;)


I'm feeling much better now.>:D
 

·
Registered
Joined
·
587 Posts
Today my dealer looked over my bike and they loosened my chain which I had tightened days before and I can say for sure it made more ruckus.. Wish they left it..... Imo it's drive lash. It's crazy bad on my bike so it's got to be stupid on yours. Especially the tq at low rpm. I know mine got better at higher revs once moving. I plan to tighten to get it back to it was. Quiet lol
 

·
Registered
Joined
·
787 Posts
Whats the mileage and air quality like in your area. I was advised I might need an air filter at 2500 miles at the sc end float check. It does sound like the engine is "chasing" . These things draw a lot of air and the air filter is asked to work hard.
 

·
Super Moderator
Joined
·
699 Posts
I took mine out in conditions it hasn't seen before ... motorway. And, we have a hiccup. The engine surges irregularly when attempting to cruise steadily at any speed between 110 and 140 km/h (70 - 85 mph) (and I didn't try faster than that). If it was carbureted, I'd raise the needles a smidge. If it had a Power Commander, I'd add a little fuel at tiny throttle position in that rev range (4500 - 6500 rpm). It's fine when accelerating, it's fine when puttering around in traffic at lower speeds.

Only diff from stock is a slip-on muffler.

Anyone else have this?
 
1 - 20 of 22 Posts
Top