Ninja H2 banner

1 - 20 of 21 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #1 ·
I'm having a somewhat difficult time keeping it idling after a high speed run. For example I''m going 60 mph give it a quick blast and then slowdown fairly hard coming to a stop and the bike dies(not always). Any thoughts or ideas? It's been doing this since brand new.
 

·
Registered
Joined
·
210 Posts
Mine too. It's not related to gas tank fuel level.

Greg
 

·
Registered
Joined
·
331 Posts
Ive ridden home from work on 110 degree days and no problems. As was suggested venting or canister problem? Is it possible idle is a tad low? does it clear up if you rev it a few times like overly rich mix? A loose battery or ground connection can cause ignition problems if fueling is ruled out. $.02
 

·
Registered
Joined
·
2,027 Posts
Doesn't this bike have small catch bowls under the frame there?Maybe the fuel overflow is full?Causing some backpressure in the tank?IDK.

Maybe not...now that I think about it,the overflow goes straight to the ground...Guess it isn't that.Is the venting and overflow the same line?
 

·
Registered
Joined
·
331 Posts
Seems like a few have the same problem. maybe it would help to see if there is a common set of conditions for everybody. Do the stalls come mainly after a hard running or does it happen sporadically even just cruising? I understand at idle the O2 sensor and ECU is closed loop and should be controlling the air and fuel. Maybe something is throwing the O2 sensor signal off? Are all the bikes still stock exhaust with cat still in?
 

·
Registered
Joined
·
74 Posts
So what I know from kawasaki is that they have no idea what the issue is i took mine in the moment this started happening and my is documented i suggest you all take yours in so they can track the issue and come up with a solution. This is covered under their warranty.
 

·
Registered
Joined
·
42 Posts
Same issue on mine bike is 100% stock. Anyone have a soultion before I void this warranty with a flash/power commander & bolt ons?
 

·
Registered
Joined
·
81 Posts
I was told by a Kawi rep that was looking at my bike that they had a similar problem before with the 636. He said they swapped out some ECU's on them to fix the problem. Mine seems fine till its above 27 degrees Celsius.
 

·
Registered
Joined
·
317 Posts
I was told by a Kawi rep that was looking at my bike that they had a similar problem before with the 636. He said they swapped out some ECU's on them to fix the problem. Mine seems fine till its above 27 degrees Celsius.
the weather in HK is very hot(33-34C) since I take my bike on July, no such problem
 

·
Registered
Joined
·
81 Posts
I have 10,000 km on my bike now and it stalled out the very first time I rode it. It stalled once today after a hard run. My Kawi dealer keeps records of it but nobody really seems to care.
 

·
Registered
Joined
·
2,027 Posts
What exactly do you mean.."hard run".Third time's a charm on my startups when cold...but that's the only deal mine is displaying.No problem for me.
 

·
Registered
Joined
·
105 Posts
I have 10,000 km on my bike now and it stalled out the very first time I rode it. It stalled once today after a hard run. My Kawi dealer keeps records of it but nobody really seems to care.

Can you explain what you were doing when it stalled? Was it on start up or while out riding?


If your Kawi dealer just keeps records and doesn't actually report it to Kawi it will stay nestled in the dealer archives.
 
1 - 20 of 21 Posts
Top