Ninja H2 banner

1 - 5 of 5 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Folks,

Whilst coming back from a ride the other day, i noticed that my gear indicator on the screen was not changing as i went up and down the box. When stopped, i can find neutral, however on the display it still says in gear. This prevents me from starting back up again unless i have the side stand up and clutch pulled in. Its not a disaster, as the bike still works, but an issue all the same.

The gear indicator is now showing 6th, and doesn't appear to want to move down from this. The downside is that the quick shifter will not let me go up a gear when in lower gears, because it thinks i'm already in 6th. Does that make sense?

Anyone else suffered this and is it an easy repair, maybe a fuse or something? Whats our warranty on these bikes? I bought it last may, so if its a big problem hopefully covered by warranty. i just had my ford ranger truck go out of warranty, and ended up paying over 500 quid for a new EGR cooler, so dont need the same to happen on the bike.

Cheers for any advice/help.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #4
cheers for the possibilities and the message about 2 yr warranty. I bought it new last may, s still got a year on it yet if its a warranty part, but if easy enough, ill change myself. Once I find out what it is ill let you guys know for future.
 

·
Registered
Joined
·
501 Posts
cheers for the possibilities and the message about 2 yr warranty. I bought it new last may, s still got a year on it yet if its a warranty part, but if easy enough, ill change myself. Once I find out what it is ill let you guys know for future.
If it were me, I'd be down to my Kwak dealer, tell them something aint right with their prestige, top of the range, expensiv bike, put it right ;)

Rob
 
1 - 5 of 5 Posts
Top