Ninja H2 banner
1 - 9 of 9 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
I'm just back from a fantastic trip to Europe to Italy for the Misano MotoGP. Bike worked great accept for one issue. After the 1st fueling abroad from the UK (in holland), the engine management light came on and it was as if i lost all acceleration and power boost and thrust. At the same time i lost the facility of cruise control. It was as if the bike had gone to a safe mode for some reason. I pulled over to the shoulder, switched the bike off, and back on again, and i seemed to regain the services id lost, power was there, boost and trust worked ok, and i had cruise control back, but the engine management light was still illuminated. After several refuel stops, even the engine light went out, so clearly its a fuelling issue. It did it several times on the way back, and even after fuelling up twice once back in the UK. Has anyone suffered this before, or any ldeas if i should do something about this? Im going to take it back to the shop as its still under warranty, but hope i have not done serious damage. Any advice is appreciated.

Graham
 

·
Registered
Joined
·
1,311 Posts
Just need to ask if the bike was in Rain mode? Assuming it wasn't, what octane rating was the fuel you bought Graham? Fuel with Ethanol of over 10% is not to be used either.

I've not heard of this before but it sounds like the bike was in a limp mode. Perhaps diagnostics will have the answer.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
Bob i put in super 95 octane the first time, and that was when i saw the light come on first time. 2nd fill was with E10 95 Octane which seemed to cause the light to go out, and filled up with this for the rest of the trip, however the light has come back on since filing up in the UK twice, so need to get it checked on the diagnostic machine i guess.
 

·
Registered
Joined
·
101 Posts
Just need to ask if the bike was in Rain mode? Assuming it wasn't, what octane rating was the fuel you bought Graham? Fuel with Ethanol of over 10% is not to be used either.

I've not heard of this before but it sounds like the bike was in a limp mode. Perhaps diagnostics will have the answer.
There is a blue pill you can take when in limp mode ;)
 

·
Registered
Joined
·
1,311 Posts
If the engine management light is ON you can press the Up/Down keys together and read a fault code from the dash. Then use the lookup table in the manual for it's meaning.

Otherwise, as you say, it's a trip do the dealer and have them plug it up to diagnostics.
 

·
Registered
Joined
·
1,023 Posts
@Arthur

Did you notice a little white umbrella on the side of the dash lit up ? Looked like a literal umbrella that you hold up in the rain. Possible you hit one of the menu buttons and it held down and turned on rain mode ?

NOLA
 

·
Registered
Joined
·
35 Posts
@Arthur

Did you notice a little white umbrella on the side of the dash lit up ? Looked like a literal umbrella that you hold up in the rain. Possible you hit one of the menu buttons and it held down and turned on rain mode ?

NOLA
The 2018 H2SX/SE doesn't have rain mode as does the H2, I believe the 2019 has added a few extra options when comes to TC
 
1 - 9 of 9 Posts
Top