Ninja H2 banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
My H2 has 700miles. I'm very irritated. When I put bike into 1st gear and release the clutch.

It engages when my clutch lever is nearly full handed open. SMH

I need to feel my bike moving as soon as I releasing it.

Has anybody experienced this with their new bike and how do I fix this issue
 

·
Registered
Joined
·
104 Posts
And the problem is.....

If you feel the action range is too small, that could be wrong/bad engine oil, wrong clutch lever setup (to high), clutch slave cylinder with a problem (dirty) or air in the hidraulics... purge it or ust change a complete charge with new DOT 4.

Check all these and confirm... if that does not fix tha feeling, go to a mechanic.
 

·
Registered
Joined
·
42 Posts
Loosen the clutch lever adjustment screw until it engages where you desire. If that does not do it, try bleeding or fluid replacement.

5000+ miles and no complaints.
 

·
Registered
Joined
·
1,412 Posts
I didn't need to adjust mine,but I experimented with both clutch and brake lever adjustments.The ODD thing I found was that it actually changed the 'place' where it starts to bite.I don't remember ANY bike(kawasaki zx14R)(12R)(zzr 1200)doing that.Only the lever moved either forward or backwards.The engagement and such never actually changed.IS this an odd setup?IDK.I should clarify maybe...with the levers all the way forward,they engaged/disengaged fine.Same with all the way rearward.(On my other bikes).My H2 seemed to not fully disengage/engage with the lever all the way forward.Is it just me?
 
1 - 5 of 5 Posts
Top