Ninja H2 banner

1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Just installed the full Akra exhaust and I get a check engine light. Is that from the O2 sensors, the (disconnected) exhaust valve servo, or something else?

help.....
 

·
Registered
Joined
·
1,311 Posts
If the ECU has been flashed the exhaust valve servo should be disabled anyway. If there's no lambda sensor fitted to the new system I suspect it's probably that causing the error. There is a bush behind the pre-muffler to fit the sensor to the Akrapovic system.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
If the ECU has been flashed the exhaust valve servo should be disabled anyway. If there's no lambda sensor fitted to the new system I suspect it's probably that causing the error. There is a bush behind the pre-muffler to fit the sensor to the Akrapovic system.
No on the flash, no on the sensor. I'll do that now and report back.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
Yep it was the O2 sensor. Light is off now. Wondering where I can get that map/flash? Is there one specific for the Akra full system?
 

·
Registered
Joined
·
265 Posts
Yep it was the O2 sensor. Light is off now. Wondering where I can get that map/flash? Is there one specific for the Akra full system?
Three options for flashing the Ecu, but you will always need to remove it from the bike:
1- Send the ECU to someone that will flash the ECU for you (Guhl/Brock)
2- Buy a DIY Flashing Kit (Woolich/FT Ecu)
3- Take the bike to a verified shop that will do all the work for you
 
1 - 7 of 7 Posts
Top