Ninja H2 banner

1 - 11 of 11 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Went to take the bike out this evening. When is started it the ABS light was on. Turned it off and on a few times, kick stand up , down , in gear, neutral. Nothing. Still on. The manual says a few things may affect this and riding it may clear it up. This is my plan for the morning. Anybody else had this happened? Got the bike Monday. Put 120 miles on it and now having issues LOL!
 

·
Registered
Joined
·
2,027 Posts
You need to be moving approx 3-5 mph first...then it should go out.If it STAYS on(while riding)...it needs to be checked at the dealer.
 

·
Registered
Joined
·
210 Posts
had the same condition with mine
turned out that one of the spring clips that go behind the pads on the front caliper had come out of its home and was loose and rattleing around i clipped it back in and has been fine since it was the right front caliper on my bike
 

·
Registered
Joined
·
135 Posts
Yes, I have had the abs light and the steering dampener light come on and stay on rode a bit then shut the bike off. Then when restarted the bike, all the lights were off. I think it was a voltage issue. Someone posted about it earlier. Since I've kept a battery tender on the bike, no issues.
Not the smallest battery tender, I think it's a 2or 4 amp. Auto on,off type. A couple of my other bikes do a similiar thing, so do the Kawasaki jet skis. With a new aftermarket battery or a fully charged stock battery no issues. Of course could be anything, but this is what happened to me.
 

·
Registered
Joined
·
210 Posts
my esd came on today as well as the triangle with the exclamation mark in it
i said wtf?
rode home got the book started reading
then went and started the bike again
all was fine wtf?
have to say the bike has been sitting for 2 weeks
all was good so i rode the **** out of it today and all was fine when parked
no problems or warnings while riding today
just lots of laughs:)
 
  • Like
Reactions: SilverbirdH2

·
Registered
Joined
·
135 Posts
Just a thought, try restarting ( resetting the computer ) a couple of times, with Kawasaki, before you go to the dealer. Just my experience. Not trying to make anyone angry.
 

·
Registered
Joined
·
48 Posts
my esd came on today as well as the triangle with the exclamation mark in it
i said wtf?
rode home got the book started reading
then went and started the bike again
all was fine wtf?
have to say the bike has been sitting for 2 weeks
all was good so i rode the **** out of it today and all was fine when parked
no problems or warnings while riding today
just lots of laughs:)
Hey mate,can I ask if you had anything hooked up to the battery to keep it charged for the 2 weeks while it wasn't ridden,just curious cause I only can go 7 days not riding it then I get a flat battery
Cheers Kozzy
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
Took it out and the light went out before i even reached the end of the driveway... just finicky or sensitive i suppose.
 

·
Registered
Joined
·
210 Posts
Hey mate,can I ask if you had anything hooked up to the battery to keep it charged for the 2 weeks while it wasn't ridden,just curious cause I only can go 7 days not riding it then I get a flat battery
Cheers Kozzy
nothing
 

·
Registered
Joined
·
8 Posts
fyi, my ESD blinked and orange triangle came on yesterday. It came on after a 65 mile ride. temps were in the mid 80's. After i stopped for gas, it self-healed and was fine again.
 
1 - 11 of 11 Posts
Top