Ninja H2 banner
1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey guys what's going on so I've had my h2 for about a year now. Never had any issues with the bike up until yesterday... me and a couple guys went for a ride bike was fine, went to do a second gear pull and the bike fell on its face loss of all power... pulled over turned bike off sat at the beach for 20 minutes or so took off home bike was fine... any insight would be a big help thanks.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Didnt try another full pull. Played with the throttle a little bit on the way home and it was fine. The bike is stock with a slip on, all levels are ok oil, antifreeze, etc. Tempature was about 170. Has just under 5k on the odometer. This was the first time it's ever done anything like this and made me a little nervous... I'm thinking maybe some bad gas, always use 93octane never anything less.
 

·
Registered
Joined
·
1,220 Posts
My guess is the tank venting. If is is a CA model the evap system can get plugged and a vacuum forms in the tank. Letting it sit allows it to normalize. If not a CA (Nevada has a CA system) it still could be a venting problem.
 

·
Registered
Joined
·
443 Posts
That's probably the problem, starving for fuel. BTW by the fuel cap on my 17 model is warns, not to use blended fuel or less than 95RON.
 

·
Registered
Joined
·
625 Posts
My guess is the tank venting. If is is a CA model the evap system can get plugged and a vacuum forms in the tank. Letting it sit allows it to normalize. If not a CA (Nevada has a CA system) it still could be a venting problem.


I completely agree Ted


Sent from my iPad using Tapatalk
 
1 - 7 of 7 Posts
Top