Clutch binding - Page 3 - Kawasaki Ninja H2 Forum
 4Likes
Reply
 
LinkBack Thread Tools
post #21 of 26 Old 02-16-2020, 01:40 PM
Senior Member
 
SilverbirdH2's Avatar
 
Join Date: Nov 2014
Posts: 1,986
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 713 Post(s)
Okay...so I'm not seeing how the pushrod cover piece could possibly not hold the slave piston even in there.The piston is machined to allow the end to fit into the pushrod cover.There's a groove for it.See that?I think it's either(on yours) a matter of greasing the pushrod ends as per the manual or there's something going on with the master at the lever. Piston moving angled?I just can't see that happening.Not with the tolerances.

h2madness!
SilverbirdH2 is offline  
Sponsored Links
Advertisement
 
post #22 of 26 Old 02-19-2020, 09:34 PM Thread Starter
Senior Member
 
Rick150's Avatar
 
Join Date: Apr 2018
Posts: 390
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
(Thread Starter)
It's fixed!
Rick150 is online now  
post #23 of 26 Old 02-20-2020, 01:50 AM
Senior Member
 
SilverbirdH2's Avatar
 
Join Date: Nov 2014
Posts: 1,986
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 713 Post(s)
You mean,by the grease addition?

h2madness!
SilverbirdH2 is offline  
 
post #24 of 26 Old 02-20-2020, 02:19 PM Thread Starter
Senior Member
 
Rick150's Avatar
 
Join Date: Apr 2018
Posts: 390
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
(Thread Starter)
Yes.
SilverbirdH2 likes this.
Rick150 is online now  
post #25 of 26 Old Today, 12:34 PM
Member
 
GlasgowH2's Avatar
 
Join Date: Sep 2017
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 23 Post(s)
Just put a little grease where the piston end touches the cylinder wall. The binding is a common problem, I posted a video here of somebody that has the trouble. Molly grease is already on the end of the rod from factory.
KHI and the dealers seem to try and avoid any direct answers yet the newer slave cylinders are of a modified type, there should be a recall.

The modified part number is 99999-0610.

I had this very issue last year in march...Kawasaki changed slave cylinder, push rod and input shaft. 3500 miles later in August that year bike lay for a few weeks and the problem happened again. Left it overnight went back out on it issue never came back rest of the season.

Went out today for the first time in 5 months....and 20 minutes on the bike the same thing is happening again. Pissed right off with this bike now.

Glad you managed to sort the issue yourself, I'm looking at doing the same this time as Kawasaki UK are useless. Can you explain in more detail where you put the grease and let me know if the issue has came back since you applied it ?

Cheers Ryan
GlasgowH2 is online now  
post #26 of 26 Old Today, 05:30 PM Thread Starter
Senior Member
 
Rick150's Avatar
 
Join Date: Apr 2018
Posts: 390
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
(Thread Starter)
When you remove the slave cylinder have some grease ready because you need to hold the piston from slowly coming out. Where the piston meets the wall of the cylinder push some grease in the gap but not a lot as you want to get the grease to lubricate the sliding piston but not the seal. Molly grease because it penetrates the hone marks and stays there.



What's happening is the rod doesn't go deep enough into the piston causing it to tilt, you can feel the metal on metal sliding on the honing. The Hydraulics are very firm that it feels like the Mater Cylinder but it's not.


Didn't bother taking it to the dealer, just told them to log it as a Warranty fault.


Did mine a few moths ago, still fixed but eventually I will probably check the grease as part of an oil change.
H2015 likes this.
Rick150 is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja H2 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome