Clutch slipping in 6th? - Kawasaki Ninja H2 Forum
 4Likes
Reply
 
LinkBack Thread Tools
post #1 of 22 Old 08-11-2019, 04:41 AM Thread Starter
Senior Member
 
Richarddps19's Avatar
 
Join Date: Nov 2018
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 142 Post(s)
(Thread Starter)
Clutch slipping in 6th?

I recently changed my rear sprocket to 42 stock H2r sprocket on my 19 C h2.

I didn’t experience this following issue till now.

All this in 6th gear. When at 12krpm under WOT the dash lights up and the bike revs a little then bike picks up hard and catches and makes quick final push to 14krpm.
Is this the clutch slipping or could it be the tire slipping and the traction control kicking in.

If it’s the clutch slipping should I reinforce the clutch by adding ebc aftermarket clutch plates?
Richarddps19 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 Old 08-11-2019, 04:57 AM
Senior Member
 
Rick150's Avatar
 
Join Date: Apr 2018
Posts: 324
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 143 Post(s)
This model should have the slipper clutch which applies more pressure as the revs increase. What is KTRC set at?
Rick150 is offline  
post #3 of 22 Old 08-11-2019, 09:48 AM
Senior Member
 
Fairclough's Avatar
 
Join Date: Oct 2018
Posts: 194
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 45 Post(s)
Quote:
Originally Posted by Richarddps19 View Post
I recently changed my rear sprocket to 42 stock H2r sprocket on my 19 C h2.

I didn’t experience this following issue till now.

All this in 6th gear. When at 12krpm under WOT the dash lights up and the bike revs a little then bike picks up hard and catches and makes quick final push to 14krpm.
Is this the clutch slipping or could it be the tire slipping and the traction control kicking in.

If it’s the clutch slipping should I reinforce the clutch by adding ebc aftermarket clutch plates?
Do you smell burnt clutch?
It sounds like tire slipping to me, if it was the clutch it would bounce off of the limiter, and usually does not regain that top end pull, and if it was just the clutch you would definitely smell that!
Fairclough is online now  
 
post #4 of 22 Old 08-11-2019, 12:53 PM Thread Starter
Senior Member
 
Richarddps19's Avatar
 
Join Date: Nov 2018
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 142 Post(s)
(Thread Starter)
Quote:
Originally Posted by Rick150 View Post
This model should have the slipper clutch which applies more pressure as the revs increase. What is KTRC set at?
Set to 1
Richarddps19 is offline  
post #5 of 22 Old 08-11-2019, 12:54 PM Thread Starter
Senior Member
 
Richarddps19's Avatar
 
Join Date: Nov 2018
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 142 Post(s)
(Thread Starter)
Quote:
Originally Posted by Fairclough View Post
Quote:
Originally Posted by Richarddps19 View Post
I recently changed my rear sprocket to 42 stock H2r sprocket on my 19 C h2.

I didn’t experience this following issue till now.

All this in 6th gear. When at 12krpm under WOT the dash lights up and the bike revs a little then bike picks up hard and catches and makes quick final push to 14krpm.
Is this the clutch slipping or could it be the tire slipping and the traction control kicking in.

If it’s the clutch slipping should I reinforce the clutch by adding ebc aftermarket clutch plates?
Do you smell burnt clutch?
It sounds like tire slipping to me, if it was the clutch it would bounce off of the limiter, and usually does not regain that top end pull, and if it was just the clutch you would definitely smell that!
No burn smell and yea it hit 12k at 6gear under WOT and then skips and hit hard and pulls away
Richarddps19 is offline  
post #6 of 22 Old 08-11-2019, 12:55 PM Thread Starter
Senior Member
 
Richarddps19's Avatar
 
Join Date: Nov 2018
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 142 Post(s)
(Thread Starter)
I will say one thing tho temps are definitely lower since putting the 42 rear
Richarddps19 is offline  
post #7 of 22 Old 08-11-2019, 01:12 PM
Senior Member
 
h2madness!'s Avatar
 
Join Date: Jun 2017
Posts: 1,399
Mentioned: 34 Post(s)
Tagged: 0 Thread(s)
Quoted: 416 Post(s)
"then skips and hit hard and pulls away"..this sounds like maybe the plates are reopening?Is it flashed?Don't they start to close around 12K on a stock motor?Maybe turn off your KTRC and see if it still does this.It's possible it could be losing a bit of traction?Maybe.That's pretty **** fast though to be losing the rear.I've run mine wot all the way up past 200.Never felt it do anything but keep pulling.Mine is set to 14,200rpm.I've only hit that a couple of times...never had anything act strange.I have a 19 on the front...

Last edited by h2madness!; 08-11-2019 at 01:27 PM.
h2madness! is online now  
post #8 of 22 Old 08-11-2019, 01:27 PM Thread Starter
Senior Member
 
Richarddps19's Avatar
 
Join Date: Nov 2018
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 142 Post(s)
(Thread Starter)
Quote:
Originally Posted by h2madness! View Post
"then skips and hit hard and pulls away"..this sounds like maybe the plates are reopening?Is it flashed?Don't they start to close around 12K on a stock motor?Maybe turn off your KTRC and see if it still does this.It's possible it could be losing a bit of traction?Maybe.That's pretty **** fast though to be losing the rear.I've run mine wot all the way up past 200.Never felt it do anything but keep pulling.Mine is set to 14,200rpm.I've only hit that a couple of times...never had anything act strange.
Yea it’s fully tuned n all. Yea it definitely at like 189-94 then it skips n dash lights up a bit n then bike kicks forward n pins it to 14k and I’m running away from other bikes.
I’m trying to look down to see what light turns on but can’t seem to focus enough at dash to tell more then upper left orange light
h2madness! likes this.
Richarddps19 is offline  
post #9 of 22 Old 08-11-2019, 01:52 PM
Senior Member
 
h2madness!'s Avatar
 
Join Date: Jun 2017
Posts: 1,399
Mentioned: 34 Post(s)
Tagged: 0 Thread(s)
Quoted: 416 Post(s)
well,you have three orange lamps on the left upper side of the dial.One is check engine light,two is fuel lamp,three is warning lamp...page 43 in the owner's manual.Probably that one lighting up.Might check those warning lamp situations in there.
h2madness! is online now  
post #10 of 22 Old 08-11-2019, 05:46 PM
Senior Member
 
OzBooster's Avatar
 
Join Date: Nov 2014
Posts: 618
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 194 Post(s)
Clutch slip usually discolors the oil pretty quickly like noticable darkening of oil color during a couple of slip events , and if bad you can smell it if you sniff the inside of the filler plug
OzBooster is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja H2 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome