Clutch won't fully disengage - Page 2 - Kawasaki Ninja H2 Forum
 5Likes
Reply
 
LinkBack Thread Tools
post #11 of 19 Old 02-02-2016, 10:48 PM
Senior Member
 
PMSHK's Avatar
 
Join Date: May 2015
Location: HONG KONG
Posts: 317
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Quote:
Originally Posted by PureRacing View Post
A rubber seal is leaking fluid and it is how Air got into my clutch lines. I added pictures
DO YOU THINK MINE IS LEAKING!

Do you want to know the truth?
Attached Thumbnails
Click image for larger version

Name:	IMG_4169.jpg
Views:	187
Size:	102.6 KB
ID:	9961   Click image for larger version

Name:	IMG_4168.jpg
Views:	183
Size:	99.3 KB
ID:	9969   Click image for larger version

Name:	IMG_4167.jpg
Views:	181
Size:	106.6 KB
ID:	9977  
jeffasaki likes this.
PMSHK is offline  
Sponsored Links
Advertisement
 
post #12 of 19 Old 02-04-2016, 12:46 AM Thread Starter
Member
 
Join Date: Nov 2015
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
(Thread Starter)
Quote:
Originally Posted by NonBock View Post


I don't see any wetness around the dust cover indicating a leak? Have you looked around the slave cylinder area near the front sprocket cover to see if there are any leaks around there?
I wiped off the fluid so I could take picture of holes where fluid is coming from. The Kawasaki dealer flushed my clutch lines because the fluid was cloudy and it was air in the lines. When I pump clutch fluid leaks out. If it's more wrong with the bike I will know when they call and tell me to come pick it up.
PureRacing is offline  
post #13 of 19 Old 02-04-2016, 06:24 PM Thread Starter
Member
 
Join Date: Nov 2015
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
(Thread Starter)
Kawasaki stated that it has been reports of master cylinder and slave cylinder leaks and is replacing my parts under warranty.
PureRacing is offline  
 
post #14 of 19 Old 02-05-2016, 02:20 PM
Senior Member
 
jeffasaki's Avatar
 
Join Date: Feb 2015
Posts: 210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 80 Post(s)
Garage
yes please

84 750 turbo
78 muliti bike z1r
82 gpz 1100
78 kz1000
02 klr 650
09 honda jazz 50
2015 NINJA H2
jeffasaki is offline  
post #15 of 19 Old 02-07-2016, 06:53 AM
Senior Member
 
PMSHK's Avatar
 
Join Date: May 2015
Location: HONG KONG
Posts: 317
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Quote:
Originally Posted by jeffasaki View Post
yes please
don't know why cannot upload the photos of the damaged slave cylinder, sorry
PMSHK is offline  
post #16 of 19 Old 02-08-2016, 01:33 PM
Senior Member
 
Join Date: Apr 2015
Location: California
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 32 Post(s)
Quote:
Originally Posted by PMSHK View Post
don't know why cannot upload the photos of the damaged slave cylinder, sorry


Are you saying that your slave cylinder was leaking, not your master cylinder?
PMSHK likes this.
NonBock is offline  
post #17 of 19 Old 02-09-2016, 03:06 AM
Senior Member
 
PMSHK's Avatar
 
Join Date: May 2015
Location: HONG KONG
Posts: 317
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Quote:
Originally Posted by nonbock View Post
are you saying that your slave cylinder was leaking, not your master cylinder?
yes, the slave cylinder wass leaking internal and the fluid burnt

Last edited by PMSHK; 02-10-2016 at 06:50 AM.
PMSHK is offline  
post #18 of 19 Old 02-14-2016, 03:48 AM
Senior Member
 
Redshift's Avatar
 
Join Date: Dec 2015
Location: France
Posts: 170
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Pics from PMSHK, he was unable to upload.
(Tip: do screenshot of pics over 950kb to reduce size)

So -do you know how/why damage happened?
Attached Thumbnails
Click image for larger version

Name:	1.jpg
Views:	182
Size:	88.9 KB
ID:	10185  
PMSHK likes this.

Last edited by Redshift; 05-01-2016 at 07:30 AM.
Redshift is offline  
post #19 of 19 Old 02-14-2016, 04:38 AM
Senior Member
 
PMSHK's Avatar
 
Join Date: May 2015
Location: HONG KONG
Posts: 317
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Quote:
Originally Posted by Redshift View Post
Pics from PMSHK, he was unable to upload.
(Tip: do screenshot of pics over 950kb to reduce size)

So -do you know how/why damage happened?
Thanks for help.

Don't know why, I found every time after play, the reservoir need to refill since brand new.
I think there were some place was leaking, I order the K-factory slave cylinder for lighter force of the clutch, after replacement, I check the original one, inside had some scratch
PMSHK is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja H2 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome